Commit 839fac8f authored by Guillaume Abrioux's avatar Guillaume Abrioux
Browse files

core: bump ansible version



We should consider bumping ansible version for future releases, so let's
start testing against ansible 2.10
Signed-off-by: default avatarGuillaume Abrioux <gabrioux@redhat.com>
parent c0785134
...@@ -15,8 +15,8 @@ Obsoletes: ceph-iscsi-ansible <= 1.5 ...@@ -15,8 +15,8 @@ Obsoletes: ceph-iscsi-ansible <= 1.5
BuildArch: noarch BuildArch: noarch
BuildRequires: ansible >= 2.9 BuildRequires: ansible >= 2.10
Requires: ansible >= 2.9 Requires: ansible >= 2.10
%if 0%{?rhel} == 7 %if 0%{?rhel} == 7
BuildRequires: python2-devel BuildRequires: python2-devel
......
# These are Python requirements needed to run ceph-ansible master # These are Python requirements needed to run ceph-ansible master
ansible>=2.9,<2.10,!=2.9.10 ansible>=2.10,<2.11,!=2.9.10
netaddr netaddr
six six
...@@ -6,8 +6,8 @@ ...@@ -6,8 +6,8 @@
- name: fail on unsupported ansible version - name: fail on unsupported ansible version
fail: fail:
msg: "Ansible version must be 2.9!" msg: "Ansible version must be 2.10!"
when: ansible_version.minor|int != 9 when: ansible_version.minor|int != 10
- name: fail on unsupported system - name: fail on unsupported system
fail: fail:
......
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
testinfra>=3,<4 testinfra>=3,<4
pytest-xdist==1.28.0 pytest-xdist==1.28.0
pytest>=4.6,<5.0 pytest>=4.6,<5.0
ansible>=2.9,<2.10,!=2.9.10 ansible>=2.10,<2.11,!=2.9.10
Jinja2>=2.10 Jinja2>=2.10
netaddr netaddr
mock mock
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment