Commit 55d0c790 authored by Guillaume Abrioux's avatar Guillaume Abrioux
Browse files

tests: install correct ansible-lint version



We need to pin the ansible-lint version depending on python version
being used.
Signed-off-by: default avatarGuillaume Abrioux <gabrioux@redhat.com>
parent 8fada835
......@@ -14,5 +14,8 @@ jobs:
with:
python-version: ${{ matrix.python-version }}
architecture: x64
- run: pip install -r <(grep ansible tests/requirements.txt) ansible-lint==4.3.7
if: matrix.python-version == '3.6'
- run: pip install -r <(grep ansible tests/requirements.txt) ansible-lint
if: matrix.python-version == '2.7'
- run: ansible-lint -x 106,204,205,208 -v --force-color ./roles/*/ ./infrastructure-playbooks/*.yml site-container.yml.sample site-container.yml.sample
\ No newline at end of file
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment