Commit 02df2ab5 authored by Dimitri Savineau's avatar Dimitri Savineau Committed by Dimitri Savineau
Browse files

tests/requirements: bump testinfra and pytest



The ansible ssh connections are now using the ssh backend instead of
paramiko starting testinfra 3.1 and persistent connections too.
pytest 4.6 is the latest release to be supported by python 2.
Signed-off-by: default avatarDimitri Savineau <dsavinea@redhat.com>
parent 2037fb87
# These are Python requirements needed to run the functional tests # These are Python requirements needed to run the functional tests
six==1.10.0 six==1.10.0
testinfra>=3.0,<3.1 testinfra>=3.2,<3.3
pytest-xdist==1.28.0 pytest-xdist==1.28.0
pytest>=4.4,<4.5 pytest>=4.6,<5.0
ansible>=2.8,<2.9 ansible>=2.8,<2.9
Jinja2>=2.10 Jinja2>=2.10
netaddr netaddr
mock mock
jmespath jmespath
paramiko
pytest-rerunfailures pytest-rerunfailures
\ No newline at end of file
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment